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Lab 2: Your first web page 

Due date 

DUE DATE: 3/3/2017, by 5pm. Demo in lab section/TA office hours. 
 

Overview 

In this lab we will walk through the usage of Microsoft Excel to create bar charts, pie charts, and 
histograms. Additionally, we will convert the charts to images and host them on our website. 
You should think along the way about why the different charts are used to convey data in 
different ways. 
 

Goal 

Learn Excel bar charts, pie charts, and histograms. Contrast which representations are better in 
which situations. 
 

Objectives 

You will create multiple of each type of chart using real data provided by the textbook. You will 
then communicate these charts by hosting them on your webpage. You will finish by answering 
questions that have you think about the data and its representation. 
 

Preparation before lab 

You should read over Activity 1.2 and 1.3 in the textbook. Ensure that your WileyPLUS account 

is linked to the course. 

Lab Description 
Your task will consist of three parts (50 points total):  

 Complete the graphing portions of Activity 1.2 and 1.3 in Excel. 

 (33 points) Add charts from Excel, with explanations, to your CSE 111 Lab 2 webpage. 

 (17 points) Complete related assigned questions on WileyPlus. 

 

Deliverables 

 cse111/lab2.html: You should update your webpage with the appropriate charts and 

explanations. 

 Images of graphs: You will need to save your images of your graphs from excel and put them in 

an images folder where lab2.html can load them. 

 lab2.xlsx: You should create all of the required charts for the lab in one file under different 

sheets. 

 Submit lab2.html and lab2.xlsx to Lab 2 on UBLearns. 

 Demo your site to a TA, in lab or office hours, and briefly discuss your explanations. 
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Instructions 

1. Read through Activity 1.2 and Activity 1.3 in the textbook. 

2. Open a new file in Excel and save it as: lab2.xlsx 

(throughout this lab, make sure you regularly save your file so you don’t lose your work) 

Activity 1.2  Medical Data and Class Data: Graphs with Excel 

3. Microsoft Excel is a powerful computer program that allows you to manipulate data and create 
graphs. (In Excel, a graph is also called a chart.) In this activity, you will use Excel to create bar graphs 
and pie charts and more importantly, you will use these charts to help understand and interpret the 
data. 

4. Change the name of the sheet from Sheet1 to ER Data. 

5.  

a) Right-click Sheet1 -> Select Rename -> Type ER Data -> Press Enter. 

6. Consider the following data on principal reasons given by patients for emergency room visits in 
2003: 

 

a) Enter the data and titles into the first two columns of an Excel worksheet, just as they appear in 
the previous table (cells A1 through B14). 
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b) Click on cell A1 and drag to cell B14 to select the data set. Then click the Insert tab and select 
Column from Charts and select Clustered column (the first type in the top row) for Chart sub-
type (if you hover your mouse over the chart type, it will display the name). 

c) To change the title of your graph, click on the title in the graph and then click again. You can 
now backspace or delete and retype a new title. 

d) To add axis titles to your graph, click inside the border of the graph. You will see the Chart 
Layouts group near the top of your screen. Click the bottom down arrow on the right edge of 
the Chart Layouts group. Click on Layout 9 (the rightmost one in the third row.) In your graph, 
click on the words “Axis Title” and type appropriate titles. Also click on the Legend and press 
Delete to remove it. 

e) Click in a blank area of the graph. The chart now has eight “handles” indicating that it has been 
“selected.” If you select a handle (getting a double-headed arrow) and then press and hold the 
left mouse button on drag it, you can resize the chart. By clicking on the white interior of the 
chart and holding down the mouse button, you can drag the chart to another location. Click 
outside the chart to “deselect” it. 

f) To sort data, return to cell A1, and then click and drag to cell B14 to select the complete set of 
data. Select the Data tab and then select Sort. Sort by Number of visits, sort on Values and 
Order Smallest to Largest. 

7. Now you'll use Excel to create a pie chart of these data. 

a) To create a pie chart, as you did before, highlight the data and labels. Go to the Insert tab and 
select Pie and the first chart sub-type, Pie, from among the choices. 

b) Click on the title to change it if needed. 

c) Click inside the graph and then click the bottom down arrow on the right edge of the Chart 
Layouts group. You will see pie chart options that allow you to label the pie pieces and/or show 
values or percents. (Note that you want to be able to clearly read the chart, so including a 
legend and data labels will make your chart easy to read.) Click on one of the Layouts. 

d) To change a bar graph to a pie chart, go back to the graph you created. Select the completed bar 
graph by clicking inside the border. 

e) From the Type group at the top left of your screen, select Change Chart Type. In the left field, 
choose Pie (for chart type) in the first box and Pie (for chart sub-type), the first choice in the 
bottom row, in the second box. Click OK. 

f) Now click inside the border of your graph to access the Chart Layouts group and choose the 
layout you want for your pie chart. 

8. Make a new sheet within Excel named Students. 

 

a) Click the + symbol to make a new sheet. 
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b) Rename this new sheet Sheet1 to Students. 

 

c) You should now have these two sheets. Make sure the new sheet Students is selected. 

9. Consider the following data on number of miles from the college to home was collected from a 
group of 12 students: 

 

a) Use Excel to create a pie chart for this data set in the sheet Students (Think about how you want 
your pie chart to show the data. You will need to put the data into categories first. You can use 
columns D and E of the same Excel worksheet.) 

b) Click on your pie chart, click Copy. Click in a cell outside of your pie chart and then click Paste. 
Change this chart to be a bar chart. 

c) Think about which chart better represents your data. 

Activity 1.3  SATs and the Super Bowl: Creating and Interpreting Histograms 

10. A histogram is a graph of a frequency distribution and is a useful way to give a pictorial summary of 
a set of data involving a quantitative variable. In this activity, you will create and interpret 
histograms. 

11. Create a new sheet in your Lab2 excel file. Rename this sheet to: SAT 

12. Download the 1.3.1 SAT data file in WileyPLUS: Read, Study, & Practice -> Topic 1 -> Excel Data File 
1.3.1 SAT data. (if you cannot find this, go to: http://bcs.wiley.com/he-
bcs/Books?action=resource&bcsId=7797&itemId=0470592710&resourceId=30212) 

http://bcs.wiley.com/he-bcs/Books?action=resource&bcsId=7797&itemId=0470592710&resourceId=30212
http://bcs.wiley.com/he-bcs/Books?action=resource&bcsId=7797&itemId=0470592710&resourceId=30212
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13. Open the file EA1.3.1 SAT data.xls, copy the two columns into your Lab2 file (Select columns A and B, 
click copy. Click the cell A1 in your Lab2 file on sheet titled SAT and click paste.) Close EA1.3.1 SAT 
data.xls. 

a) You should be working in Lab2.xlsx on sheet SAT. 

b) One way to create histograms is to use the Insert tab discussed previously. The Insert tab is 
designed to use with data that have been grouped—either categorical data or quantitative 
data—into classes or intervals. To create a histogram using the Insert tab, you will group the 
data, which is not too difficult if you first sort it. 

c) You'll create a histogram of the “percent taking SATs” for all the states, so first sort the data by 
this column; however, be sure to highlight both columns and then begin to perform the sort. 
Select the Data tab and Sort, and then sort by the appropriate column from smallest to largest. 

d) Next decide what the “bins” will be. That is, you need to decide what classes (of equal width) to 
use to group the data. For this data set, it appears that 0 < % ≤ 10; 10 < % ≤ 20; 20 < % ≤
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30, and so on will be convenient classes. Use your sorted data to count the number of data 
values that fall into each of these classes, and create a table in columns E and F of your Excel 
worksheet with the class labels in column E and the frequencies for each class in column F. 
(Include axis titles.) 

e) Use this table of classes and frequencies, and create a bar graph like you did previously. 

f) To make this completed bar graph look like a histogram, adjacent bars should touch one 
another. To change the bar width, right-click on one of the bars of the finished graph to access 
the Format data series dialog box. From Series Options, change the Gap width from 150% to 
0%. Then click Close. 

g) You may add titles and experiment with some of the other features of bar graphs (like adding or 
taking away axis labels and so on). 

14. Here is another method to create a histogram with Excel. For this histogram, you'll use a file 
containing data about the points scored by the winning team in the Super Bowl for the years 1967 to 
2011. 

15. Make a new sheet in your Lab2.xlsx file and name it: Super Bowl 

16. Retrieve the “EA1.3.2 Super Bowl.xls” file from the text website or WileyPLUS. You'll make a 
histogram of the variable “points scored by winner.”  

17. Open the file EA1.3.2 Super Bowl.xls, copy the two columns into your Lab2 file (Select columns A 
and B, click copy. Click the cell A1 in your Lab2 file on sheet titled Super Bowl and click paste.) Close 
EA1.3.2 Super Bowl.xls. (if you cannot find this, go to: http://bcs.wiley.com/he-
bcs/Books?action=resource&bcsId=7797&itemId=0470592710&resourceId=30212) 
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a) You can also create a histogram using Excel's Analysis ToolPak, which groups the data into 
classes for you. 

b) The ToolPak may need to be installed; to check, choose the Data tab. If the Ribbon shows an 
Analysis group, select Data Analysis from the Analysis group. If Data Analysis is not shown on 
the Ribbon, proceed as follows to install the Analysis ToolPak. 

i. To install the Analysis ToolPak: Click on File and then click Options at the bottom of the 
menu window that opens. Choose Add-Ins on the left box under Excel Options, and at 
the bottom of the Add-Ins box, for the Manage box, select Excel Add-Ins. 

ii. Click Go. In the Add-Ins available box, select the Analysis ToolPak check box, and then 
click OK. (If Analysis ToolPak is not listed in the Add-Ins available box, click Browse to 
locate it.) If you get a prompt indicating that the Analysis ToolPak is not currently 
installed on your computer, click Yes to install it. 

c) From the menu bar, choose Data and then Data analysis from the Analysis group; scroll down 
to the Histogram option and click OK. 

d) In the dialog box, type the reference for the range of your data, B1:B46 in the Input range area, 
or click and drag from cell B1 to cell B46. Leave the Bin range field blank to allow Excel to select 
the bins (or groupings) for your data. Check the Labels box because B1 (where there is a label 
for the column) has been included in the Input range. Click to select Output range and Type C1 
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for Output range to denote the upper left cell of the output range, and check the box Chart 
output to put the histogram on the same sheet of the workbook as the data. For now, you won't 
use the other options (Pareto and Cumulative percentage.) Click OK. 

e) The output entries under Bin in the C column are the upper limits of the boundaries for each 
class, and the corresponding frequencies appear in cells in the D column. (Notice the numbers at 
the bottom of each bar in the histogram.) 

f) Adjacent bars should touch in a histogram. To change the bar width, right-click one of the bars 
to bring up the Format data series dialog box. On Series Options, change the Gap width from 
150% to 0%. Then click Close. 

g) To create a slightly different histogram using “bin” intervals that you choose, type My Bins (or 
any other appropriate label) in cell E1. (You may need to move your histogram.) Because the 
data values range from 14 to 55, you can use intervals of width 5, beginning with the interval 
from 10 to 15. So enter the values 15, 20, 25, 30, 35, 40, 45, 50, 55 in cells E2:E10. (This creates 
the bins or classes of: 10 < points scored ≤ 15; 15 < points scored ≤ 20; 20 < points scored ≤ 25; 
and so on, to the last class, 50 < points scored ≤ 55.) Notice that the right endpoint of each 
interval or class is included in the interval but the left endpoint is not. 

h) Use the procedure for creating a histogram described previously, but type E1:E10 in the Bin 
range area and type G1 for Output range.  

18. Some Selected Enhancements to Your Histogram 

a) Here is an additional way to get rid of the legend. To do this, click the legend (the word 
frequency on the chart). Select the Layout tab. Click Legend (in the Labels group) and select 
None to turn off the Legend Option. 

b) You can resize both the plot area (the gray region containing the histogram) and the larger 
rectangle by clicking in the boundaries and dragging the appropriate handles horizontally, 
vertically, or diagonally. Click outside the chart to “deselect.” 

c) To change the chart title, click the title word Histogram. A rectangular gray border with handles 
will surround the word. Click the word Histogram again and type an appropriate title. When 
finished, click outside the graph. 

d) Click the words My Bins at the bottom of the chart and type in an appropriate X-axis title. 

e) The More interval with 0 counts shouldn't be there. In the workbook cell containing the word 
More, change the label to 60. The histogram is dynamically linked to the data and the label on 
the X-axis changes to 60. 

Save your charts as images 

19. From each of your sheets, you will need to save one of the charts you generated: 

a) Click on the sheet and click on a chart. 
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b) Open Microsoft Word. Paste the chart. Select Paste options:

 

Click the Picture option: 

 

c) Right-click the picture and select “Save as Picture…” 

 

d) Save the file with the same name as the sheet the chart came from. 

20. At the end of this, you should have 4 images: ER.png, Students.png, SAT.png, Super Bowl.png 
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Within lab2.html 

21. Open the folder containing your lab2.html files (Open Windows Explorer -> S:\public_html\cse111 

22. Create a folder called: images inside your cse111 folder. 

23. Copy all 4 images created previously into the folder images. 

24. Open your lab2.html file. 

25. Scroll down to the part of the file with the text:  

<p> 
       <!-- Content. --> 
</p> 

a) Following this you should create 4 pairs of 2 rows as follows: 

i. <div class=”row”> 

<img src=”images/CHART-NAME.png” alt=”Chart description”> 

</div> 

ii. <div class=”row”> 

<p> 

 Description of information conveyed in chart. 

</p> 

</div> 

iii. Here, you should replace CHART-NAME.png with the appropriate names of the images 
you created.  

iv. You should replace Chart description with the title of your chart. 

v. The description should explain what the chart is showing and a conclusion you can draw 
from the chart. 

b) When this is completed, the 4 images should be visible on your webpage with an appropriate 
description of each chart. 

Within WileyPLUS Lab 2 Questions 

26. Complete the assigned questions Lab 2 Questions on WileyPLUS. 

 

IMPORTANT: These are required for getting a grade for your lab. 

1. Make sure you upload lab2.xlsx and lab2.html to Lab 2 on UBLearns. 
2. Make sure you complete the assigned questions on WileyPLUS. 
3. Demo your work to the TA, showing your files are hosted on your website and briefly 

explain your charts. 
 
 

DUE DATE: 3/3/2017, by 5pm. Demo in your lab section/TA office hours. 


